Drivers ATI en Ubuntu Dapper

[Actualización 3/12/2007: WordPress se empeña en traducir dos guiones “- -” (sin el espacio entre ellos) por un guión largo “–“. Los guiones dobles se utilizan con el comando ‘aticonfig’, en la segunda parte de la instalación.

[Actualización 30/09/2006: Todos mis problemas con ATI han terminado después de instalar la beta de Ubuntu 6.10]

Éstos son los pasos que he seguido para activar la aceleración 3D en mi ATI 9200 SE, utilizando este sources.list.

Paso 0. Eliminar el controlado fglrx instalado.

Eliminamos el driver fglrx
sudo aptitude remove xorg-driver-fglrx
Instalamos (si no estaba ya instalado) el driver ATI.
sudo aptitude install xserver-xorg-driver-ati
sudo dpkg-reconfigure xserver-xorg

Seleccionar el driver ‘ati’ y aceptar, sin más el resto de opciones. Reiniciar el sistema.

Paso 1. Actualizar los repositorios y descargar los paquetes necesarios.

sudo aptitude update
sudo aptitude install module-assistant build-essential
sudo aptitude install fakeroot dh-make debconf libstdc++5 gcc-3.3-base
sudo aptitude install linux-restricted-modules-$(uname -r)
sudo gedit /etc/default/linux-restricted-modules-common

Modificar DISABLED_MODULES=”” por DISABLED_MODULES=”fglrx”.

Paso 2. Instalación

Descargar el “driver installer” de ATI
Crear un directorio donde hacer las operaciones cd
mkdir ati-install

Mover allí el archivo descargado (en mi caso ati-driver-installer-8.26.18-x86.run).
Ejecutar las siguientes instrucciones

chmod +x ati-driver-installer-8.26.18-x86.run
./ati-driver-installer-8.25.18-x86.run --buildpkg Ubuntu/dapper
sudo dpkg -i xorg-driver-fglrx_8.26.18-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.26.18-1_i386.deb
sudo dpkg -i fglrx-control_8.26.18-1_i386.deb
sudo rm /usr/src/fglrx-kernel*.deb
sudo module-assistant prepare,update
sudo module-assistant build,install fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
sudo ln -s /usr/lib/dri /usr/lib/xorg/modules/dri
wget http://www.ground-impact.com/libGL.so.1.2
sudo mv /usr/lib/libGL.so.1.2 /usr/lib/old-libGL.so.1.2
sudo cp ./libGL.so.1.2 /usr/lib/
sudo cp ./libGL.so.1.2 /usr/lib/fglrx/

Reiniciar el sistema.

Paso 3. Verificación.

Lo primero que hay que hacer es otro reinicio del sistema para que se carguen los nuevos módulos.

glxinfo | grep direct direct rendering: Yes
glxgears -iacknowledgethatthistoolisnotabenchmark
4232 frames in 5.0 seconds = 846.360 FPS
4244 frames in 5.0 seconds = 848.624 FPS
4202 frames in 5.0 seconds = 833.853 FPS
4234 frames in 5.0 seconds = 846.776 FPS
4196 frames in 5.0 seconds = 839.147 FPS
4195 frames in 5.0 seconds = 838.957 FPS
4198 frames in 5.0 seconds = 839.516 FPS
fglrxinfo
display: :0.0 screen: 0 OpenGL
vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1080 (X4.3.0-8.26.6)

ACTUALIZACIÓN Después de actualizar el kernel hay que volver a ejecutar las siguientes instrucciones (y reiniciar el sistema) para que los drivers vuelvan a funcionar.
sudo module-assistant prepare,update
sudo module-assistant build,install fglrx
sudo depmod -a

7 comentarios en “Drivers ATI en Ubuntu Dapper”

  1. Tengo un notebook HP ze2000 con Slackware, me podrias indicar como instalar el ATI video … ?
    compilo el ATI driver pero la resolucion es pesima …?

  2. ademas obtengo este error que no se como solucionar
    root@DaGa:~# glxinfo | grep direct
    Error: unable to open display (null)
    root@DaGa:~#

  3. Muchas gracias por el tutorial, me ha venido como anillo al dedo. Funciona perferctamente mi ATI 9200 con 3D

    Algunos errores tipográficos sin trascendencia
    En el paso dos pones:
    ./ati-driver-installer-8.25.18-x86.run –buildpkg Ubuntu/dapper
    y es ./ati-driver-installer-8.26.18-x86.run –buildpkg Ubuntu/dapper (26 y no 25 y los dos guiones antes de buildpkg

    sudo aticonfig –initial por sudo aticonfig –-initial

  4. #3. Gracias por el comentario. Lo de los guiones ‘–‘ es cosa del bueno del WP que se empeña en traducirlos como un guión largo. Para que no le pille desprevenido a nadie, he actualizado el texto de la entrada.

  5. Un profesional.

    Ahora a quedado maqueado. La verdad que es una gozada instalar la aceleración 3d a base de ctrl+c ctrl+v desde tu web a la consola.

    Lo de los guiones me percate cuando mi propio post apereció como guión largo.

    Gracias otra vez y un detallazo que lo hayas corregido para los que vengan detrás.

  6. no se pueden crear los packages dise Distro Version entered incorrectly or not supported uso el back track 4 que deberia hacer
    si me pueden ayudar recien me cambie a linux
    gracias de antemano

  7. me parece que el back track esta basado en ubuntu 8.10
    deberia cambiarle el nobre a el comando final

Los comentarios están cerrados.